OpenGL sehr langsamm(1-2 FPS)

Für sonstige Unterhaltungen, welche nicht direkt mit Lazarus zu tun haben

OpenGL sehr langsamm(1-2 FPS)

Beitragvon pluto » 23. Dez 2006, 23:15 OpenGL sehr langsamm(1-2 FPS)

Hallo,
nachdem ich es endlich geschaft habe openGL zu installieren ist es sehr langsamm.
Sobalt ich ein spiel starte was OpenGL betnutz habe ich ca 1-2 fps.

ich habe ein Aspire 1350 mit eine Unichrome KM400 KN400 grafikschipsatzt !

ich weiß einfach nicht mehr weiter....
habe heute den halben tag damit verbracht mit google nach hinweisen zu suchen.
Und habe alle möglichekn packte installiert - deinstalliert aber zu einem guten ergbnis bin ich leider nicht gekommen und ich finde einfach nichts was mir weiter helfen könnte !!!
MFG
Michael Springwald
Aktuelles Projekt: PlutoArduino
pluto
 
Beiträge: 6702
Registriert: 19. Nov 2006, 12:06
Wohnort: Oldenburg/Oldenburg
OS, Lazarus, FPC: Linux Mint 18.3 | 
CPU-Target: AMD
Nach oben

Beitragvon Euklid » 24. Dez 2006, 12:01

Hallo Pluto!

Das klingt ganz nach einem Graphikkartentreiberproblem.
Wenn der Treiber nicht oder nicht richtig installiert ist, übernimmt die CPU einen Großteil der Arbeit der Graphikkarte. Dadurch kommt es dann zu so niedrigen Bildraten.

Viele Grüße, Euklid
Euklid
 
Beiträge: 2760
Registriert: 22. Sep 2006, 09:38
Wohnort: Hessen

Beitragvon pluto » 24. Dez 2006, 14:43

und was kann ich dagen tuen ?
ich habe nur eine onbord grafik karte.... und nach der installation liev openGL zwar konnte nicht alles dagstellt werden aber es lief.
MFG
Michael Springwald
Aktuelles Projekt: PlutoArduino
pluto
 
Beiträge: 6702
Registriert: 19. Nov 2006, 12:06
Wohnort: Oldenburg/Oldenburg
OS, Lazarus, FPC: Linux Mint 18.3 | 
CPU-Target: AMD
Nach oben

Beitragvon Christian » 24. Dez 2006, 22:58

Was machst du denn eigentlich bei was hast du 1-2 fps ?
W.m.k.A.h.e.m.F.h. -> http://www.gidf.de/
Christian
 
Beiträge: 6101
Registriert: 21. Sep 2006, 06:51
Wohnort: Dessau
OS, Lazarus, FPC: iWinux (L 1.x.xy FPC 2.y.z) | 
CPU-Target: AVR,ARM,x86(-64)
Nach oben

Beitragvon pluto » 25. Dez 2006, 12:09

ja ich habe 1-2 FPS und ich weiß nicht warum !
das spiel stammt nicht von mir !
ich habe zwar denn qullcode davon aber der ist in c oder c++ geschrieben !

das ist ein problem was linux allgmein bei mir hat !

und ich habe stundenlang mit google gesucht aber leider nicht gefunden
MFG
Michael Springwald
Aktuelles Projekt: PlutoArduino
pluto
 
Beiträge: 6702
Registriert: 19. Nov 2006, 12:06
Wohnort: Oldenburg/Oldenburg
OS, Lazarus, FPC: Linux Mint 18.3 | 
CPU-Target: AMD
Nach oben

Beitragvon theo » 25. Dez 2006, 13:32

pluto hat geschrieben:und ich habe stundenlang mit google gesucht aber leider nicht gefunden


Habe keine Ahnung. Hast Du hier mal gekuckt?
http://www.openchrome.org/

Vielleicht solltest du auch ein spezifischeres Forum suchen.
theo
 
Beiträge: 8064
Registriert: 11. Sep 2006, 18:01

Beitragvon schnullerbacke » 25. Dez 2006, 16:55

LINUX kommt meistens ohne 3D-Beschleuniger. Da mußt Du mal gezielt nach nem passenden Treiber für deine Karte suchen. Bei ATI und NVIDIA gibt es für LINUX meistens eigene Treiber, da solltest du fündig werden.
Humor ist der Knopf, der verhindert, daß uns der Kragen platzt.

(Ringelnatz)
schnullerbacke
 
Beiträge: 1189
Registriert: 13. Dez 2006, 10:58
Wohnort: Hamburg
OS, Lazarus, FPC: Winux (L 1.2.xy FPC 2.6.z) | 
CPU-Target: AMD A4-6400 APU
Nach oben

Beitragvon Christian » 25. Dez 2006, 17:32

kopier mail die gesamte ausgabe von "glxinfo" hier rein
W.m.k.A.h.e.m.F.h. -> http://www.gidf.de/
Christian
 
Beiträge: 6101
Registriert: 21. Sep 2006, 06:51
Wohnort: Dessau
OS, Lazarus, FPC: iWinux (L 1.x.xy FPC 2.y.z) | 
CPU-Target: AVR,ARM,x86(-64)
Nach oben

Beitragvon pluto » 26. Dez 2006, 15:07

Code: Alles auswählen
pluto@Pegasus:~$ glxinfo
name of display: :0.0
libGL warning: 3D driver claims to not support visual 0x46
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_EXT_texture_from_pixmap, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_hyperpipe,
    GLX_SGIX_swap_barrier, GLX_SGIX_fbconfig, GLX_MESA_copy_sub_buffer
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_copy_sub_buffer, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_OML_sync_control,
    GLX_SGI_make_current_read, GLX_SGI_swap_control, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig, GLX_SGIX_pbuffer,
    GLX_SGIX_visual_select_group, GLX_EXT_texture_from_pixmap
GLX version: 1.2
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_swap_control,
    GLX_MESA_swap_frame_usage, GLX_OML_swap_method, GLX_SGI_video_sync,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig
OpenGL vendor string: VIA Technology
OpenGL renderer string: Mesa DRI UniChrome (KM400) 20060710
OpenGL version string: 1.2 Mesa 6.5.1
OpenGL extensions:
    GL_ARB_imaging, GL_ARB_multisample, GL_ARB_multitexture,
    GL_ARB_point_parameters, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_mirrored_repeat,
    GL_ARB_transpose_matrix, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
    GL_EXT_clip_volume_hint, GL_EXT_compiled_vertex_array, GL_EXT_convolution,
    GL_EXT_copy_texture, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
    GL_EXT_histogram, GL_EXT_packed_pixels, GL_EXT_point_parameters,
    GL_EXT_polygon_offset, GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_lod_bias, GL_EXT_texture_object, GL_EXT_vertex_array,
    GL_APPLE_packed_pixels, GL_IBM_rasterpos_clip,
    GL_IBM_texture_mirrored_repeat, GL_MESA_window_pos, GL_NV_blend_square,
    GL_NV_light_max_exponent, GL_NV_texgen_reflection, GL_OES_read_format,
    GL_SGI_color_matrix, GL_SGI_color_table, GL_SGIS_texture_edge_clamp,
    GL_SGIS_texture_lod
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess
 
   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x22 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x23 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8  0  0  0  0  0 0 None
0x24 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  0  0  0  0  0  0 0 None
0x25 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  0  0  0  0  0  0 0 None
0x26 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x27 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
0x28 24 tc  0 32  0 r  y  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x29 24 tc  0 32  0 r  .  .  8  8  8  8  0 24  8 16 16 16 16  0 0 Slow
0x2a 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  0 16 16 16 16  0 0 Slow
0x2b 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  0 16 16 16 16  0 0 Slow
0x2c 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x2d 24 tc  0 32  0 r  .  .  8  8  8  8  0  0  0 16 16 16 16  0 0 Slow
0x46 32 tc  0 32  0 r  .  .  8  8  8  8  0  0  0  0  0  0  0  0 0 Ncon
MFG
Michael Springwald
Aktuelles Projekt: PlutoArduino
pluto
 
Beiträge: 6702
Registriert: 19. Nov 2006, 12:06
Wohnort: Oldenburg/Oldenburg
OS, Lazarus, FPC: Linux Mint 18.3 | 
CPU-Target: AMD
Nach oben

Beitragvon pluto » 26. Dez 2006, 15:16

vom link habe ich mir jetzt "libxvmc_0.1.32-1_i386.deb" installiert es scheint wieder zu gehen... allerdings geht clonk z.b. immer noch nicht da kommt die meldung:
Code: Alles auswählen
pluto@Pegasus:/media/hda1/spiele/ce4955$ ./clonk
[15:15:53] Command line:
[15:15:53] ""
libGL warning: 3D driver claims to not support visual 0x46
[15:15:53] Clonk Endeavour Network2 Alpha 1 (Forfix)
[15:15:53] Version: 4.96.0NET2 [215]
[15:15:53] Registered to: Michael Springwald (Michael_Springwald) [14976013]
[15:15:53]   Size of GammaRamp is not 256
[15:15:53]   Using OpenGL...
[15:15:53]   XF86VidModeExtension version is 2.2
[15:15:53]   1024x768 ht: 1344 vt: 806 hss: 1048 hse: 1184 vss: 770 vse: 776 f: 10 dc: 65028 hsk: 0
[15:15:53]   gl: Requested display mode not found; leaving current!
The program 'clonk' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 924 error_code 2 request_code 135 minor_code 18)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
pluto@Pegasus:/media/hda1/spiele/ce4955$

und ich weiß nicht warum !
MFG
Michael Springwald
Aktuelles Projekt: PlutoArduino
pluto
 
Beiträge: 6702
Registriert: 19. Nov 2006, 12:06
Wohnort: Oldenburg/Oldenburg
OS, Lazarus, FPC: Linux Mint 18.3 | 
CPU-Target: AMD
Nach oben

Beitragvon Christian » 26. Dez 2006, 23:58

Ich versteh mal wieder nicht was du machst deine ausgabe vom glxinfo zeigt eindeutig das du keinen treiber benutzt der hardware rendering unterstützt also wird die mesa benutzt (software rendering) was deine framerates erklärt aber was libxvmc nun mit dem ganzen zu tun haben soll .... ?
W.m.k.A.h.e.m.F.h. -> http://www.gidf.de/
Christian
 
Beiträge: 6101
Registriert: 21. Sep 2006, 06:51
Wohnort: Dessau
OS, Lazarus, FPC: iWinux (L 1.x.xy FPC 2.y.z) | 
CPU-Target: AVR,ARM,x86(-64)
Nach oben

Beitragvon pluto » 27. Dez 2006, 15:17

naja ich muste gestern linux neu installieren(komplet)

libxvmc ?
schau ich mal nacher nach !
MFG
Michael Springwald
Aktuelles Projekt: PlutoArduino
pluto
 
Beiträge: 6702
Registriert: 19. Nov 2006, 12:06
Wohnort: Oldenburg/Oldenburg
OS, Lazarus, FPC: Linux Mint 18.3 | 
CPU-Target: AMD
Nach oben

• Themenende •

Zurück zu Dies und Das



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

porpoises-institution
accuracy-worried