Package-List vom OPM wird nicht geladen

Rund um die LCL und andere Komponenten

Package-List vom OPM wird nicht geladen

Beitragvon Linkat » 19. Dez 2017, 18:17 Package-List vom OPM wird nicht geladen

Habe mit Lazarus 1.8.0 den Online Package Managers (OPM) (sowohl unter Windows 7, als aúch unter Linux Mint 18.3 Cinnamon) erfolgreich installiert. Nach Aufrufen des Online Package Managers soll die Package-List geladen werden. Aber es kommt folgende Fehlermeldung (s. Anhang, unter Windows erfolgt eine ähnliche Fehlermeldung):

Wie kann ich den Remote-Server erreichen?

Gruß, Linkat
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Linkat
 
Beiträge: 383
Registriert: 10. Sep 2006, 22:24
Wohnort: nr Stuttgart
OS, Lazarus, FPC: Linux Mint 18.3 64 bit; Lazarus 1.8.0 FPC 3.0.4; Raspbian, Windows 7 | 
CPU-Target: AMD 64Bit, ARM 32Bit
Nach oben

Beitragvon Mathias » 19. Dez 2017, 18:22 Re: Package-List vom OPM wird nicht geladen

Versuche es mal ein bisschen später, evtl. ist der Server nicht erreichbar.
Wobei es bei mir gegenwärtig funktioniert.
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot
Mathias
 
Beiträge: 3993
Registriert: 2. Jan 2014, 17:21
Wohnort: Schweiz
OS, Lazarus, FPC: Linux (die neusten Trunc) | 
CPU-Target: 64Bit
Nach oben

Beitragvon wp_xyz » 19. Dez 2017, 18:37 Re: Package-List vom OPM wird nicht geladen

Wenn du im OPM auf "Options" gehst, erscheint die URL zum Remote Repository. Steht da "http://packages.lazarus-ide.de"? Als "Connection Timeout" sind bei mir 10 s eingetragen. Ggfs. "Restore defaults" klicken. Im Fall eines Proxy müssen die entsprechenden Angaben auf der Seite "Proxy" gemacht werden.
wp_xyz
 
Beiträge: 2533
Registriert: 8. Apr 2011, 08:01

Beitragvon Linkat » 19. Dez 2017, 19:47 Re: Package-List vom OPM wird nicht geladen

Unter Options/Einstellungen finde ich unter Allgemein (s. Anhang) die URL, aber keine Einstellung für Connection Timeout. Proxy nutze ich von zuhause nicht.

Hat noch jemand eine Idee?
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Linkat
 
Beiträge: 383
Registriert: 10. Sep 2006, 22:24
Wohnort: nr Stuttgart
OS, Lazarus, FPC: Linux Mint 18.3 64 bit; Lazarus 1.8.0 FPC 3.0.4; Raspbian, Windows 7 | 
CPU-Target: AMD 64Bit, ARM 32Bit
Nach oben

Beitragvon wp_xyz » 19. Dez 2017, 23:48 Re: Package-List vom OPM wird nicht geladen

Kannst du packages.lazarus-ide.org anpingen?
wp_xyz
 
Beiträge: 2533
Registriert: 8. Apr 2011, 08:01

Beitragvon Linkat » 20. Dez 2017, 20:53 Re: Package-List vom OPM wird nicht geladen

So, jetzt habe versucht die packages.lazarus-ide.org an zu pingen. Nach gefühlten 2 Minuten habe ich mit Strg C abgebrochen. Das Resultat steht im Anhang. Ich habe verschiedene Adressen angepingt, manche haben funktioniert (z.B. heise.de) manche nicht (z.B. ebay.de) hier werden nur Pakete gesendet, aber nicht empfangen (s. Anhang).

Hat jemand eine Erklärung?

Gruß, Linkat
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Linkat
 
Beiträge: 383
Registriert: 10. Sep 2006, 22:24
Wohnort: nr Stuttgart
OS, Lazarus, FPC: Linux Mint 18.3 64 bit; Lazarus 1.8.0 FPC 3.0.4; Raspbian, Windows 7 | 
CPU-Target: AMD 64Bit, ARM 32Bit
Nach oben

Beitragvon wp_xyz » 20. Dez 2017, 21:03 Re: Package-List vom OPM wird nicht geladen

Virenscanner? Firewall? Vielleicht ist packages.lazarus-ide.org auf eine schwarze Liste gelangt?
wp_xyz
 
Beiträge: 2533
Registriert: 8. Apr 2011, 08:01

Beitragvon Linkat » 20. Dez 2017, 22:05 Re: Package-List vom OPM wird nicht geladen

Auf meinem Laptop mit Linux Mint 18.3 habe ich keine Virenscanner. Das Linux ist standardmässig aufgesetzt, ohne Modifikationen an der Firewall. In der Firma (Win7) kann durchaus eine Black List existieren. Werde ich morgen prüfen. Ich wundere mich, dass scheinbar niemand das gleiche Problem hat.

Aber ich möchte jetzt keinen grossen Aufwand mehr in den Online Package Manager stecken. Meine drei wichtigsten Komponenten (Industrial Stuff, EC-Components und ZEOS) habe ich wie früher manuell installiert.

Vielen Dank wp_xyz.


Gruß, Linkat
Linkat
 
Beiträge: 383
Registriert: 10. Sep 2006, 22:24
Wohnort: nr Stuttgart
OS, Lazarus, FPC: Linux Mint 18.3 64 bit; Lazarus 1.8.0 FPC 3.0.4; Raspbian, Windows 7 | 
CPU-Target: AMD 64Bit, ARM 32Bit
Nach oben

Beitragvon Mathias » 20. Dez 2017, 22:27 Re: Package-List vom OPM wird nicht geladen

So, jetzt habe versucht die packages.lazarus-ide.org an zu pingen. Nach gefühlten 2 Minuten habe ich mit Strg C abgebrochen.


Hast du evtl. die Datei /etc/hosts verändert ?
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot
Mathias
 
Beiträge: 3993
Registriert: 2. Jan 2014, 17:21
Wohnort: Schweiz
OS, Lazarus, FPC: Linux (die neusten Trunc) | 
CPU-Target: 64Bit
Nach oben

Beitragvon Linkat » 21. Dez 2017, 20:08 Re: Package-List vom OPM wird nicht geladen

@Mathias, die /etc/hosts habe ich nicht verändert.

Am Windows 7 (FirmenPC) kann ich mit 'packages.lazarus-ide.org' die Seite im Firefox laden, aber nichts downloaden.
An meinem Linux Mint 18.3 PC kann ich die Seite nicht laden. Nach einiger Zeit kommt die Fehlermeldung "Netzwerk Zeitüberschreitung".

Alles nur noch seltsam!
Linkat
 
Beiträge: 383
Registriert: 10. Sep 2006, 22:24
Wohnort: nr Stuttgart
OS, Lazarus, FPC: Linux Mint 18.3 64 bit; Lazarus 1.8.0 FPC 3.0.4; Raspbian, Windows 7 | 
CPU-Target: AMD 64Bit, ARM 32Bit
Nach oben

• Themenende •

Zurück zu Komponenten und Packages



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 7 Gäste

porpoises-institution
accuracy-worried