[Gelöst] ReadXMLFile: Problem beim Parsen von XML Datei

Rund um die LCL und andere Komponenten

Re: [Gelöst] ReadXMLFile: Problem beim Parsen von XML Datei

Beitragvon pluto » 21. Jan 2019, 23:35 Re: [Gelöst] ReadXMLFile: Problem beim Parsen von XML Datei

Ich bearbeite regelmäßig Stücklisten von SAP, in welchen <n/a> vorkommt...

Vielleicht gibt es verschiedene Versionen oder Varianten davon? Wie das gehandhabt wird....
MFG
Michael Springwald
Aktuelles Projekt: PlutoArduino
pluto
 
Beiträge: 6848
Registriert: 19. Nov 2006, 12:06
Wohnort: Oldenburg/Oldenburg
OS, Lazarus, FPC: Linux Mint 18.3 | 
CPU-Target: AMD
Nach oben

Beitragvon BeniBela » 21. Jan 2019, 23:56 Re: [Gelöst] ReadXMLFile: Problem beim Parsen von XML Datei

Den Parser, den ich für meine Internet Tools geschrieben habe, macht aus der Eingabe

Code: Alles auswählen
<e2servicename><n /a=""/></e2servicename>
BeniBela
 
Beiträge: 253
Registriert: 21. Mär 2009, 17:31
OS, Lazarus, FPC: Linux (Lazarus SVN, FPC 2.4) | 
CPU-Target: 64 Bit
Nach oben

Beitragvon MacWomble » 22. Jan 2019, 11:33 Re: [Gelöst] ReadXMLFile: Problem beim Parsen von XML Datei

Richtiger wäre, wenn der Parser aus <n/a> einfach n/a machen würde, oder eben doch vorher ersetzen.
Alle sagten, dass es unmöglich sei - bis einer kam und es einfach gemacht hat.
MacWomble
 
Beiträge: 743
Registriert: 17. Apr 2008, 00:59
Wohnort: Freiburg
OS, Lazarus, FPC: Mint 19 Cinnamon / CodeTyphon Generation V Plan 6.60 | 
CPU-Target: Intel i7 64/32 Bit
Nach oben

• Themenende •
Vorherige

Zurück zu Komponenten und Packages



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 7 Gäste

porpoises-institution
accuracy-worried