fpcupdeluxe error Lazarus Trunk

Für Installationen unter Windows

fpcupdeluxe error Lazarus Trunk

Beitragvon sstvmaster » 26. Jul 2018, 21:02 fpcupdeluxe error Lazarus Trunk

Hi,

wollte heute mal meinen Trunk wieder aktualisieren. Nun kommt bei der Kompilierung von Lazarus folgende Meldung:

Code: Alles auswählen
 
(1021) 1 warning(s) issued
(1022) 17 hint(s) issued
(1023) 14 note(s) issued
(3104) Compiling .\win32\win32wsgrids.pp
(3104) Compiling .\win32\win32wsmenus.pp
(3104) Compiling .\win32\win32wsspin.pp
(1002) Target OS: Win32 for i386
(3104) Compiling datetimectrls.pas
(3104) Compiling datetimepicker.pas
C:\fpcupdeluxe\lazarus\lcl\interfaces\.\win32\win32winapi.inc(1314,51) Error: (4025) Incompatible type for arg no. 3: Got "<procedure variable type of function(var ENUMLOGFONTEXA;var NEWTEXTMETRICEXA;LongInt;LongInt):LongInt;StdCall>", expected "<procedure variable type of function(var ENUMLOGFONTEXW;var NEWTEXTMETRICEXW;LongInt;LongInt):LongInt;StdCall>"
win32int.pp(358) Fatal: (10026) There were 1 errors compiling module, stopping
Fatal: (1018) Compilation aborted
Error: C:\fpcupdeluxe\fpc\bin\i386-win32\ppc386.exe returned an error exitcode
Error: (lazarus) Compile package LCL 1.9: stopped with exit code 1
(3104) Compiling calcontrolwrapper.pas
Error: (lazarus) Compile package DateTimeCtrls 1.5.1: terminated
Error: (lazarus) [TLazPackageGraph.CompileRequiredPackages] "Exit code 1"
 
fpcupdeluxe: ERROR: UniversalInstaller (ConfigModule: suggestedpackages): Failure trying to rebuild Lazarus.
Details:
 
 
ERROR: Fpcupdeluxe fatal error !
 


Was kann ich tun?

LG Maik
OS: Windows 7 32/64bit
Lazarus 1.8.4, 32bit
Lazarus 2.1.0 Trunk 3.3.1, 32bit
sstvmaster
 
Beiträge: 84
Registriert: 22. Okt 2016, 22:12
OS, Lazarus, FPC: Lazarus 1.8.4 + 2.1.0 Trunk 3.3.1 / Win32, Windows 7 32+64bit | 
CPU-Target: 32Bit
Nach oben

Beitragvon wp_xyz » 26. Jul 2018, 22:12 Re: fpcupdeluxe error Lazarus Trunk

Das ist ein Bug, der, wie ich gerade sehe, seit 10 Min auf "resolved" gesetzt ist.

Aber ehrlich: Warum tust du dir solche Probleme an, indem du mit FPC-Trunk arbeitest? Meine Standard-Arbeitsumgebung ist FPC 3.0.4 - die letzte stabile FPC-Version - und Lazarus-Trunk, weil ich die neueste Version brauche. Und mit SVN ist es auch einfach, eine ältere Revision zurückzuspielen und sich in 1 Minute wieder einen funktionierenden Lazarus zu kompilieren. Wenn dasselbe mit FPC passiert, ist der Vorgang viel langwieriger. Und die allerneuesten FPC-Features benutze ich sowieso nicht, sondern eher altbackenes Pascal, anstatt dem modernen C++/Java/Pascal-Mischdialekt.
wp_xyz
 
Beiträge: 2645
Registriert: 8. Apr 2011, 08:01

Beitragvon Timm Thaler » 26. Jul 2018, 23:30 Re: fpcupdeluxe error Lazarus Trunk

wp_xyz hat geschrieben:Warum tust du dir solche Probleme an, indem du mit FPC-Trunk arbeitest?


AVR embedded geht sinnvoll nur mit dem neuesten FPC Trunk.
Timm Thaler
 
Beiträge: 707
Registriert: 20. Mär 2016, 22:14
OS, Lazarus, FPC: Win7-64bit Laz1.9.0 FPC3.1.1 für Win, RPi, AVR embedded | 
CPU-Target: Raspberry Pi 3
Nach oben

Beitragvon Mathias » 27. Jul 2018, 15:53 Re: fpcupdeluxe error Lazarus Trunk

Aber ehrlich: Warum tust du dir solche Probleme an, indem du mit FPC-Trunk arbeitest?

Wie Timm schon schreibt wegen AVR.
Auch ist es neugier, was neues geboten wird.

PS: Ich habe es gerade probiert, in einem neunen Ordner ist fpcupdeluxe fehlerfrei durchgelaufen. Ich habe es mit Linux 64Bit probiert.
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot
Mathias
 
Beiträge: 4327
Registriert: 2. Jan 2014, 17:21
Wohnort: Schweiz
OS, Lazarus, FPC: Linux (die neusten Trunc) | 
CPU-Target: 64Bit
Nach oben

• Themenende •

Zurück zu Windows



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

porpoises-institution
accuracy-worried