Can't call the resource compiler [gelöst]

Für Installationen unter Linux-Systemen

Can't call the resource compiler [gelöst]

Beitragvon u-boot » 29. Sep 2016, 20:40 Can't call the resource compiler [gelöst]

Nach langer Abstinenz will ich doch mal wieder Lazarus installieren (nein ich hatte es nicht gelöscht aber die Systeme halten nicht so ewig.....)
Bin momentan mit Ubuntu 14 LTS ausgestattet.
habe FPC 3.0.0 mit "everything in one big file" heruntergeladen, nachher entpackt.
bei Lazarus habe ich heute SVN Revision 53056 heruntergeladen.
gtk2 "-Krempel" habe ich über Synaptic ganz normal für Ubuntu installiert (ich hoffe doch soweit vollständig)
zusätzlichen Pfad mit -FD in ~/.fcp.cfg eingetragen


im Lazarusverzeichnis habe ich dann dieses "Phänomen":

Code: Alles auswählen
make LCL_PLATFORM=gtk2 FPC=~/fpc-3.0.0/lib/fpc/3.0.0/ppcx64 
 
...
 
(9022) Compiling resource ../units/x86_64-linux/gtk2/lazarus.or
~/lazarus/ide/lazarus.pp(154,1) Error: (9030) Can't call the resource compiler "~/fpc-3.0.0/bin/fpcres", switching to external mode
~/lazarus/ide/lazarus.pp(154,1) Fatal: (10026) There were 1 errors compiling module, stopping
Fatal: (1018) Compilation aborted
make[2]: *** [lazarus] Fehler 1
make[2]: Verzeichnis ~/lazarus/ide wird verlassen
make[1]: *** [ide] Fehler 2
make[1]: Verzeichnis ~/lazarus/ide wird verlassen
make: *** [ide] Fehler 2

Für eine bessere Lesbarkeit wurden in der Ausgabe die absoluten Pfade von /home/$userdir/ durch ~/ ersetzt


fpcres ist genau im angegebenen Pfad vorhanden. Berechtigung von fpcres hab ich mal auf 777 gesetzt. Bringt aber nichts.
Wo hab ich jetzt den Fehler eingebaut?
Zuletzt geändert von u-boot am 30. Sep 2016, 06:38, insgesamt 1-mal geändert.
Ubuntu 9.10 (L 0.9.28 FPC 2.4.x)
u-boot
 
Beiträge: 297
Registriert: 9. Apr 2009, 09:10
Wohnort: 785..
OS, Lazarus, FPC: Ubuntu 9.10 (L 0.9.28 FPC 2.2.4) | 
CPU-Target: 32Bit
Nach oben

Beitragvon u-boot » 30. Sep 2016, 06:38 Re: Can't call the resource compiler

OK habe den Fehler gefunden. libgtk2.0-dev hat gefehlt. :oops:

Trotzdem dafür etwas seltsame Fehlermeldung.....
Ubuntu 9.10 (L 0.9.28 FPC 2.4.x)
u-boot
 
Beiträge: 297
Registriert: 9. Apr 2009, 09:10
Wohnort: 785..
OS, Lazarus, FPC: Ubuntu 9.10 (L 0.9.28 FPC 2.2.4) | 
CPU-Target: 32Bit
Nach oben

• Themenende •

Zurück zu Linux



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

porpoises-institution
accuracy-worried