Kubuntu LTS 18.04 Installation nicht möglich

Für Installationen unter Linux-Systemen

Kubuntu LTS 18.04 Installation nicht möglich

Beitragvon Aliobaba » 6. Sep 2018, 09:49 Kubuntu LTS 18.04 Installation nicht möglich

Hallo,

Ich richtete gestern auf einem neuen PC auf eine jungfräuliche Festplatte die Kubuntu-Version "Ubuntu 18.04.1 LTS" ein. Der Installationsprozess lief völlig problemlos durch.
Und natürlich wollte ich sogleich (und als erstes gestern installierte Programm überhaupt: Also auf ein wirklich "jungfäuliches" System) Lazarus installieren. Diese derzeit wohl aktuellen Installationsdateien von github habe ich verwendet:

file:///home/ali/Downloads/fpc_3.0.2-170225_amd64.deb
file:///home/ali/Downloads/fpc-src_3.0.2-170225_amd64.deb
file:///home/ali/Downloads/lazarus-project_1.6.4-0_amd64.deb

Und dies ist das verwendete Betriebssystem:
Code: Alles auswählen
 
ali@PCAli:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.1 LTS"
ali@PCAli:~$

Leider ist die Installation vollständig misslungen und, wie ich nun sehe, bin ich nicht alleine mit diesem Problem:
https://www.lazarusforum.de/viewtopic.php?f=3&t=11535
https://www.lazarusforum.de/viewtopic.php?f=3&t=11515

Irgendwann gestern konnte ich dann Lazarus "rudimentär" starten und im "Begrüßungstext"
"Willkommen zur Lazarus IDE 1.6.4 -> Lazarus IDE einrichten" waren die Reiter "FPC-Quellen" und "Make" mit einem roten Ausrufezeichen versehen.

Ich durchsuchte dann das Internet und irgendwie kam es, dass nur noch der Reiter "Make" das rote Ausrufezeichen hatte
(weiß leider nicht mehr, welche Maßnahme dann irgendwann zu diesem "Teilerfolg" führte) :
Code: Alles auswählen
make->
"Datei:
Fehler: Datei nicht gefunden"

Daraufhin schaute ich auf meine Installation auf dem alten PC; hier konnte ich sehen, dass das Programm "make" hier zu finden sein sollte: "usr/bin/make"
Hier ist es auch auf meinem alten PC, nicht aber auf meinem neuen PC.
Auf dem neuen PC gab es dieses "Make"-Programm nicht. Also: Fehler gefunden --- dachte ich.

Und ich dachte, dass es ja nicht so schwer sein kann, dieses "make" zu installieren. Aber leider verlaufen meine Versuche (sh. Fußnoten) im Sande.

Kann mir hier jemand weiter helfen??

Offenbar bin ich ja nicht alleine mit dem Problem, dass sich "Lazarus" auf der aktuellen LTS-Version von Kubuntu nicht installieren lässt. Dies finde ich extrem schade, da es sicherlich einige an Lazarus Interessierte davon abhält, sich mit "Lazarus" zu beschäftigen.

Viele Grüße
Aliobaba


<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
Code: Alles auswählen
 
ali@PCAli:~$ sudo apt install make   
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paket make ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.
 
E: Für Paket »make« existiert kein Installationskandidat.


Code: Alles auswählen
 
ali@PCAli:~$ sudo apt-get install --reinstall make
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paket make ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.
 
E: Für Paket »make« existiert kein Installationskandidat.
ali@PCAli:~$

<<<<<<<<<<<<<<<<<<<<<

Code: Alles auswählen
ali@PCAli:~$ sudo apt-get install build-essential
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 build-essential : Hängt ab von: libc6-dev soll aber nicht installiert werden oder
                                  libc-dev
                   Hängt ab von: gcc (>= 4:7.2) soll aber nicht installiert werden
                   Hängt ab von: g++ (>= 4:7.2) soll aber nicht installiert werden
                   Hängt ab von: make
                   Hängt ab von: dpkg-dev (>= 1.17.11) soll aber nicht installiert werden
 lazarus-project : Hängt ab von: libgtk2.0-dev (>= 2.6.0) soll aber nicht installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).
ali@PCAli:~$

<<<<<<<<<<<<<

Code: Alles auswählen
ali@PCAli:~$ sudo gedit /etc/apt/sources.list
sudo: gedit: command not found
 
ali@PCAli:~$ sudo apt-get install gedit
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 gedit : Hängt ab von: libgspell-1-1 (>= 1.0.0) soll aber nicht installiert werden
         Hängt ab von: libgtksourceview-3.0-1 (>= 3.21.5) soll aber nicht installiert werden
         Hängt ab von: libpeas-1.0-0 (>= 1.14.1) soll aber nicht installiert werden
         Hängt ab von: gir1.2-gtksource-3.0 (>= 3.21.2) soll aber nicht installiert werden
         Hängt ab von: gedit-common (>= 3.28) soll aber nicht installiert werden
         Hängt ab von: gedit-common (< 3.29) soll aber nicht installiert werden
         Hängt ab von: python3-gi-cairo (>= 3.0) soll aber nicht installiert werden
         Hängt ab von: gir1.2-peas-1.0 soll aber nicht installiert werden
         Empfiehlt: zenity
         Empfiehlt: yelp soll aber nicht installiert werden
 lazarus-project : Hängt ab von: libgtk2.0-dev (>= 2.6.0) soll aber nicht installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).
ali@PCAli:~$

<<<<<<<<<<<<<<

Eine abschließende Frage:
Code: Alles auswählen
Hängt ab von: libc6-dev soll aber nicht installiert werden oder libc-dev
Hängt ab von: gcc (>= 4:7.2) soll aber nicht installiert werden
Hängt ab von: g++ (>= 4:7.2) soll aber nicht installiert werden

Bedeutet das "soll aber nicht installiert werden", dass einem davon abgeraten wird, dies zu installieren oder nur, dass es eben nicht angefordert worden ist?
Ich trau mich nicht recht, diesen Befehl auch noch auszuprobieren, da ich offenbar bei meinem alten PC schon genug Unheil angerichtet habe. (Wahrscheinlich durch "Basteleien" an der Python-Installation)
(Aber ich wollte so und so schon länger einen neuen PC aufsetzen - und nun muss ich eben)
"MyMemoryDB" ( https://www.heise.de/download/product/mymemorydb-89626 )
Aliobaba
 
Beiträge: 349
Registriert: 1. Mai 2012, 08:11

Beitragvon Aliobaba » 6. Sep 2018, 10:44 Re: Kubuntu LTS 18.04 Installation nicht möglich

Hallo,

dieser Befehl: "apt --fix-broken install" hat soeben offenbar geholfen :)
Vielleicht hilft mein Problem ja irgend einem anderen und spart ihm eine Menge "Lebenszeit".
Aber "Lernen" ist ja ein Wert an sich. :)

Gruß
Aliobaba

Anhang:
" In the worst case scenario where you have no clue about the name of the Packages then follow the commands given below:
sudo apt-get --fix-broken install "

Die Begriffe "no clue" und "worst case" passen für mich recht gut in diesem Zusammenhang ... 8) :oops:
[http://omgfoss.com/how-to-fix-broken-packages-in-ubuntu-18-04-lts/]
"MyMemoryDB" ( https://www.heise.de/download/product/mymemorydb-89626 )
Aliobaba
 
Beiträge: 349
Registriert: 1. Mai 2012, 08:11

• Themenende •

Zurück zu Linux



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

porpoises-institution
accuracy-worried