Bgrabitmap-9.8.1 auf Raspi - FEHLER

Rund um die LCL und andere Komponenten

Bgrabitmap-9.8.1 auf Raspi - FEHLER

Beitragvon DL3AD » 17. Jun 2018, 09:42 Bgrabitmap-9.8.1 auf Raspi - FEHLER

Hallo,
auf einem Raspi3 habe ich Lazarus 1.6.2 laufen - nun wollte ich das Paket Bgrabitmap-9-8-1 installieren.
Beim kompilieren des Paketes gibt es folgenden Fehler

bgragtkbitmap.pas (191,46) Error: identifies idents no member "width"
bgragtkbitmap.pas (191,60) Error: identifies idents no member "Height"
.
.
.

Wie komme ich da weiter ?
Auf meiner Win7 installation mit Lazarus 1.8.0 läuft das Paket

Gruß Frank
Zuletzt geändert von DL3AD am 17. Jun 2018, 17:50, insgesamt 1-mal geändert.
DL3AD
 
Beiträge: 368
Registriert: 13. Sep 2013, 11:07
Wohnort: Rügen
OS, Lazarus, FPC: Win7 (L 1.8.0 FPC 3.0.4) und Debian Stretch (L 1.8.0 FPC 3.0.4) | 
CPU-Target: 32Bit/64Bit
Nach oben

Beitragvon Mathias » 17. Jun 2018, 16:19 Re: Bgrabitmap-9.8.1 auf Raspi - FEHLER

Ich habe es gerade mit meinem Cross-Compiler probiert, da bekomme ich keinen Fehler. Plattform Linux / arm / ARMV7A

Lazarus und FPC sind die neusten Trunk. Vielleicht liegt es daran, das du ein altes Lazarus verwendest.

Was für ein FPC hast du ?
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot
Mathias
 
Beiträge: 4258
Registriert: 2. Jan 2014, 17:21
Wohnort: Schweiz
OS, Lazarus, FPC: Linux (die neusten Trunc) | 
CPU-Target: 64Bit
Nach oben

Beitragvon DL3AD » 17. Jun 2018, 17:00 Re: Bgrabitmap-9.8.1 auf Raspi - FEHLER

Hallo,

Lazarus 1.6.2 läuft auf dem Raspi
Habe es mit einer älteren Version Bgrabitmap-9-7-2 versucht - nun funktioniert es.
Ab der Version Bgrabitmap-9-8-0 tritt der Fehler auf.

Gruß Frank
DL3AD
 
Beiträge: 368
Registriert: 13. Sep 2013, 11:07
Wohnort: Rügen
OS, Lazarus, FPC: Win7 (L 1.8.0 FPC 3.0.4) und Debian Stretch (L 1.8.0 FPC 3.0.4) | 
CPU-Target: 32Bit/64Bit
Nach oben

Beitragvon Mathias » 17. Jun 2018, 17:35 Re: Bgrabitmap-9.8.1 auf Raspi - FEHLER

Etwas ist bei dir komisch, ich kann die Dateien bei deiner Fehlermeldung in der aktuellen BGRABitmap nicht mal finden.

Ich denke, du hatte sonst noch irgendwelche Konflikte.
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot
Mathias
 
Beiträge: 4258
Registriert: 2. Jan 2014, 17:21
Wohnort: Schweiz
OS, Lazarus, FPC: Linux (die neusten Trunc) | 
CPU-Target: 64Bit
Nach oben

Beitragvon DL3AD » 17. Jun 2018, 17:52 Re: Bgrabitmap-9.8.1 auf Raspi - FEHLER

ohhh sorry die Datei ist bgragtkbitmap.pas und nicht bgragthbitmap.pas
DL3AD
 
Beiträge: 368
Registriert: 13. Sep 2013, 11:07
Wohnort: Rügen
OS, Lazarus, FPC: Win7 (L 1.8.0 FPC 3.0.4) und Debian Stretch (L 1.8.0 FPC 3.0.4) | 
CPU-Target: 32Bit/64Bit
Nach oben

Beitragvon Mathias » 17. Jun 2018, 18:57 Re: Bgrabitmap-9.8.1 auf Raspi - FEHLER

Jetzt habe ich die Datei gefunden.

Noch eine Frage, ist deine FPC-Version auf dem Raspi kleiner als 3.0.0 ?

Lazarus-IDE --> Hilfe --> Über Lazarus --> Version
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot
Mathias
 
Beiträge: 4258
Registriert: 2. Jan 2014, 17:21
Wohnort: Schweiz
OS, Lazarus, FPC: Linux (die neusten Trunc) | 
CPU-Target: 64Bit
Nach oben

Beitragvon DL3AD » 18. Jun 2018, 09:16 Re: Bgrabitmap-9.8.1 auf Raspi - FEHLER

Lazarus 1.6.2 mit FPC 3.0.0
SVN- Revision: 56259
DL3AD
 
Beiträge: 368
Registriert: 13. Sep 2013, 11:07
Wohnort: Rügen
OS, Lazarus, FPC: Win7 (L 1.8.0 FPC 3.0.4) und Debian Stretch (L 1.8.0 FPC 3.0.4) | 
CPU-Target: 32Bit/64Bit
Nach oben

Beitragvon Mathias » 18. Jun 2018, 17:49 Re: Bgrabitmap-9.8.1 auf Raspi - FEHLER

Dies hatte ich gestern auch gehabt, konnte aber den Fehler nicht reproduzieren.
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot
Mathias
 
Beiträge: 4258
Registriert: 2. Jan 2014, 17:21
Wohnort: Schweiz
OS, Lazarus, FPC: Linux (die neusten Trunc) | 
CPU-Target: 64Bit
Nach oben

• Themenende •

Zurück zu Komponenten und Packages



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste

porpoises-institution
accuracy-worried