Lazarus unter Ubuntu

Beitragvon Christian » 15. Feb 2007, 13:38

in /etc darf jeder user schreiben ? seit wann das mir ist kein verzeichnis bekannt in das jeder user schreiben darf wenn du doch sowas findest sag bescheid
W.m.k.A.h.e.m.F.h. -> http://www.gidf.de/
Christian
 
Beiträge: 6101
Registriert: 21. Sep 2006, 06:51
Wohnort: Dessau
OS, Lazarus, FPC: iWinux (L 1.x.xy FPC 2.y.z) | 
CPU-Target: AVR,ARM,x86(-64)
Nach oben

Beitragvon schnullerbacke » 15. Feb 2007, 14:00

Habsch auch nicht behauptet, aber wenn du die Gruppenzugehörigkeit des Verzeichnisses auf "users" anstatt auf "root" setzt, also auch unter-vz, dann darf jeder user mit mit account dann in das VZ schreiben wenn die Schreibrechte für die Gruppe gesetzt sind.

In /etc braucht der user auch nix schreiben, aber lazarus kann bei der Installation da seine Config-scripte ablegen (auch per Symlink), dann gilt das für jeden Benutzer, der die Anwendung starten darf. Dann darf allerdings auch nur "root" die Lazarus-Umgebung erweitern.
Humor ist der Knopf, der verhindert, daß uns der Kragen platzt.

(Ringelnatz)
schnullerbacke
 
Beiträge: 1189
Registriert: 13. Dez 2006, 10:58
Wohnort: Hamburg
OS, Lazarus, FPC: Winux (L 1.2.xy FPC 2.6.z) | 
CPU-Target: AMD A4-6400 APU
Nach oben

Beitragvon Christian » 15. Feb 2007, 16:15

Lazarus hat aber keine einzige konfigurationsdatei die nicht geändert wird ! Aber das mit der gruppe users is n guter tipp meien installer können ja n config dir machen :)
W.m.k.A.h.e.m.F.h. -> http://www.gidf.de/
Christian
 
Beiträge: 6101
Registriert: 21. Sep 2006, 06:51
Wohnort: Dessau
OS, Lazarus, FPC: iWinux (L 1.x.xy FPC 2.y.z) | 
CPU-Target: AVR,ARM,x86(-64)
Nach oben

Beitragvon u-boot » 12. Nov 2009, 22:35 Re: Lazarus unter Ubuntu

Bei Aktualisierung wäre die Anleitung noch hilfreicher. Folgende Pakete konnte ich leider nicht den Namen zuordnen, die in der Anleitung stehn:

fpc_2.2.4-3_all.deb
fp-docs_2.2.4-3_all.deb
fp-units-i386_2.2.4-3_i386.deb
fp-units-multimedia_2.2.4-3_i386.deb

Das crosswin-Paket ist nun extra und nicht mehr direkt enthalten.
u-boot
 
Beiträge: 297
Registriert: 9. Apr 2009, 09:10
Wohnort: 785..
OS, Lazarus, FPC: Ubuntu 9.10 (L 0.9.28 FPC 2.2.4) | 
CPU-Target: 32Bit
Nach oben

Beitragvon corpsman » 13. Nov 2009, 08:14 Re: Lazarus unter Ubuntu

Übrigens, man kann auch mehrere Packete gleichzeitig installieren lassen:


sudo dpkg -i OrdnerName/*.deb


dpkg findet hierbei selbst eine geeignete Reihenfolge und installiert dann.
corpsman
 
Beiträge: 1037
Registriert: 28. Feb 2009, 08:54
Wohnort: Stuttgart
OS, Lazarus, FPC: Kubuntu 14.04, Lazarus SVN Trunk, FPC 3.0 | 
CPU-Target: 32Bit
Nach oben

Beitragvon Maik81ftl » 28. Apr 2011, 12:20 Re: Lazarus unter Ubuntu

Könnte da ggf mal eine Info bzw ein Paralelles Thema für die aktuellen versionen bereitgestellt werden??? und wie schaut's denne bei mir aus (info's in der sig) wenn keine pixbuf verfügbar ist?
Maik81ftl
 
Beiträge: 619
Registriert: 9. Mär 2011, 16:34
Wohnort: seit 01.06.2011 in Wahlstedt
OS, Lazarus, FPC: Ubuntu10.04 LTS (L 0.9.31.0 FPC 2.4.4) | 
CPU-Target: 64Bit
Nach oben

Beitragvon Euklid » 28. Apr 2011, 20:54 Re: Lazarus unter Ubuntu

In der aktuellen ubuntu-Version habe ich keine Probleme mehr damit, Lazarus direkt aus den Ubuntu-Paketquellen zu installieren. Läuft tadellos.
Euklid
 
Beiträge: 2756
Registriert: 22. Sep 2006, 09:38
Wohnort: Hessen

Beitragvon Maik81ftl » 28. Apr 2011, 21:04 Re: Lazarus unter Ubuntu

Euklid hat geschrieben:In der aktuellen ubuntu-Version habe ich keine Probleme mehr damit, Lazarus direkt aus den Ubuntu-Paketquellen zu installieren. Läuft tadellos.


nun Leider wird in der Ubuntu 10.04 LTS noch Lazarus 0.9.28.2-Beta angeboten. aber hab's dennoch mit der 0.9.30. hinbekommen, nur des Crosskompileren bekomm i net hn.
Maik81ftl
 
Beiträge: 619
Registriert: 9. Mär 2011, 16:34
Wohnort: seit 01.06.2011 in Wahlstedt
OS, Lazarus, FPC: Ubuntu10.04 LTS (L 0.9.31.0 FPC 2.4.4) | 
CPU-Target: 64Bit
Nach oben

Beitragvon MAC » 29. Apr 2011, 10:30 Re: Lazarus unter Ubuntu

selbst nicht in der aktuellen Ubutnu 11.4 wird Lazarus in Version 0.9.30 angeboten.

Wie installiert man das aktuellele lazarus denn ?
ich hab mit auf lazarus sourceforge die x86_64 deb packete von lazarus und fpc geladen. FPC kann man ohne probleme installieren, aber bei Lazarus lösen sich die Abhängigkeiten nie auf:

Wenn ich die all variante haben will wird die ide benötigt , dafür wird gt2 benöigt, das benötigt aber wieder die ide --> endlosschleife ? das gleiche ist auch bei qt4

Code: Alles auswählen
// packet --> benötigtes packet
lazarus-0.9.30_0.9.30-0_all --> lazarus-ide-0.9.30_0.9.30-0_amd64
lazarus-ide-0.9.30_0.9.30-0_amd64 --> lazarus-ide-gtk2-0.9.30_0.9.30-0_amd64
lazarus-ide-gtk2-0.9.30_0.9.30-0_amd64 --> lazarus-ide-0.9.30_0.9.30-0_amd64
MAC
 
Beiträge: 770
Registriert: 21. Feb 2009, 13:46
OS, Lazarus, FPC: Windows 7 (L 1.3 Built 43666 FPC 2.6.2) | 
CPU-Target: 32Bit
Nach oben

Beitragvon Maik81ftl » 29. Apr 2011, 14:16 Re: Lazarus unter Ubuntu

also hab ich doch keine macke :lol: genau das Problem hatte ich auch. hab mich denne für 'nen Konsolen befehl entschieden. nur statt Lazarus hab ich lazarus-0.9.30.0 eingegeben.
Maik81ftl
 
Beiträge: 619
Registriert: 9. Mär 2011, 16:34
Wohnort: seit 01.06.2011 in Wahlstedt
OS, Lazarus, FPC: Ubuntu10.04 LTS (L 0.9.31.0 FPC 2.4.4) | 
CPU-Target: 64Bit
Nach oben

Beitragvon MAC » 29. Apr 2011, 14:36 Re: Lazarus unter Ubuntu

ah, welcher befehlt war das , denn die abhängigkeit kann einen schon irgendwie verwirren...
MAC
 
Beiträge: 770
Registriert: 21. Feb 2009, 13:46
OS, Lazarus, FPC: Windows 7 (L 1.3 Built 43666 FPC 2.6.2) | 
CPU-Target: 32Bit
Nach oben

Beitragvon Maik81ftl » 29. Apr 2011, 14:48 Re: Lazarus unter Ubuntu

MAC hat geschrieben:ah, welcher befehlt war das , denn die abhängigkeit kann einen schon irgendwie verwirren...


entweder schaust hier viewtopic.php?f=16&t=4951 oder tippst
Code: Alles auswählen
sudo apt-get install lazarus-0.9.30


Hat mich auch generft ohne ende. und monta wollte ja mal ein tut für aktuelle versionen posten. aber hat wohl a sehr viel streß inna uni.

Edit nur bei dem Cross-Compiler bin ich noch am Verzweifeln.
Maik81ftl
 
Beiträge: 619
Registriert: 9. Mär 2011, 16:34
Wohnort: seit 01.06.2011 in Wahlstedt
OS, Lazarus, FPC: Ubuntu10.04 LTS (L 0.9.31.0 FPC 2.4.4) | 
CPU-Target: 64Bit
Nach oben

Beitragvon MAC » 29. Apr 2011, 16:17 Re: Lazarus unter Ubuntu

ok, ich hätte jetzt nicht gedacht das man mit dem apt-get install befehl ne version bekommt die nicht in der softwareverwaltung drinn ist, aber wenn du's sagt.
Ich probiers gleich aus.

Edit: funktioniert nicht, er kennt das packet nicht.
Deshalb hab ich das ganze ohne "-"

Code: Alles auswählen
sudo apt-get install lazarus 0.9.30


gemacht.
Laut der ausgabe hat es sich so angehört als ob er auch wirklich 0.9.30 instaliieren will...
als er meinte es wäre fertig starte aber ein lazarus mit 0.9.28.2 im ladebild- das ist sofort abgestürtz.
Daraufhin hab ich jede mange damit rumgespielt (einfach mal alle kombinationen ausprobiert. altes lazarus installiert , wieder entfernt...)
und jetzt kann ich lazarus nicht mehr richtig entfernen...

Edit2:
hab es jetzt mit Softwarecenter ohne probleme entfernt. Wenn ich
Code: Alles auswählen
sudo apt-get install lazarus 0.9.30

verwende labert es am anfang von 0.9.30 , wenn ich dann aber mit "j" bestätige heißten die ganzen dateien 0.9.28.2-12 : böööse :)
MAC
 
Beiträge: 770
Registriert: 21. Feb 2009, 13:46
OS, Lazarus, FPC: Windows 7 (L 1.3 Built 43666 FPC 2.6.2) | 
CPU-Target: 32Bit
Nach oben

Beitragvon Maik81ftl » 29. Apr 2011, 18:00 Re: Lazarus unter Ubuntu

MAC hat geschrieben:ok, ich hätte jetzt nicht gedacht das man mit dem apt-get install befehl ne version bekommt die nicht in der softwareverwaltung drinn ist, aber wenn du's sagt.
Ich probiers gleich aus.

Edit: funktioniert nicht, er kennt das packet nicht.
Deshalb hab ich das ganze ohne "-"

Code: Alles auswählen
sudo apt-get install lazarus 0.9.30


gemacht.
Laut der ausgabe hat es sich so angehört als ob er auch wirklich 0.9.30 instaliieren will...
als er meinte es wäre fertig starte aber ein lazarus mit 0.9.28.2 im ladebild- das ist sofort abgestürtz.
Daraufhin hab ich jede mange damit rumgespielt (einfach mal alle kombinationen ausprobiert. altes lazarus installiert , wieder entfernt...)
und jetzt kann ich lazarus nicht mehr richtig entfernen...

Edit2:
hab es jetzt mit Softwarecenter ohne probleme entfernt. Wenn ich
Code: Alles auswählen
sudo apt-get install lazarus 0.9.30

verwende labert es am anfang von 0.9.30 , wenn ich dann aber mit "j" bestätige heißten die ganzen dateien 0.9.28.2-12 : böööse :)


Jopp! mit dem hab ich a noch zu kämpfen, das ich auf die 0.9.28.2-beta drauf hatte.

Bekomme denne immer die Meldung, das er 2 Settigs findet und ich wähle denne die System. zum Einstellen, sollte man aber mal den root laufen lassen. und vorsichtshalber den Ordner für alle voll geben, auch denne von vorteil, wenn du eigene Package da rein haben willst.

Edit! Fall jemand interesse hat. nach ich mal ein tut, wenn ich mein rechner mit Ubuntu 10.04 LTS / OS 10.3 aufsetze.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Maik81ftl
 
Beiträge: 619
Registriert: 9. Mär 2011, 16:34
Wohnort: seit 01.06.2011 in Wahlstedt
OS, Lazarus, FPC: Ubuntu10.04 LTS (L 0.9.31.0 FPC 2.4.4) | 
CPU-Target: 64Bit
Nach oben

Beitragvon Socke » 30. Apr 2011, 14:47 Re: Lazarus unter Ubuntu

MAC hat geschrieben:
Code: Alles auswählen
sudo apt-get install lazarus 0.9.30

verwende labert es am anfang von 0.9.30 , wenn ich dann aber mit "j" bestätige heißten die ganzen dateien 0.9.28.2-12 : böööse :)

Du hast die Meldung schon gelesen, oder? Mit dem Befehl willst du nämlich zwei Pakete installieren, und es ist sehr wahrscheinlich, dass es das Paket mit dem Namen "0.9.30" nicht gibt...
Socke
 
Beiträge: 2484
Registriert: 22. Jul 2008, 18:27
Wohnort: Köln
OS, Lazarus, FPC: Lazarus: SVN; FPC: svn; Win 8.1/Debian GNU/Linux/Raspbian/openSUSE | 
CPU-Target: 32bit x86 armhf
Nach oben

» Weitere Beiträge siehe nächste Seite »
VorherigeNächste

Zurück zu Installation



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

porpoises-institution
accuracy-worried