Forum Weiterleitung crasht

Für Dinge zum Forum, Kritik, Verbesserungsvorschläge, Umfragen und ähnliches.
Marsmännchen
Beiträge: 294
Registriert: So 4. Mai 2014, 21:32
OS, Lazarus, FPC: Ubuntu 16.04, FPC 3.0.2, Lazarus 1.6.4
CPU-Target: 64bit
Wohnort: Berlin

Forum Weiterleitung crasht

Beitrag von Marsmännchen »

Hi,
Wenn ich eine Antwort hier in einem Thread erstelle, dann kommt ja erst eine Meldung, dass die Antwort erfolgreich gespeichert wurde und dann versucht mich die Website in diesen Thread weiterzuleiten. Dabei knallt es bei mir immer mit folgender Meldung:
Fehler: Gesicherte Verbindung fehlgeschlagen

An error occurred during a connection to www.lazarusforum.de:80. SSL received a record that exceeded the maximum permissible length. Error code: SSL_ERROR_RX_RECORD_TOO_LONG


Ich benutzeFirefox 53.0.3+build1-0ubuntu0.16.04.2
Ich mag Pascal...

Mathias
Beiträge: 5039
Registriert: Do 2. Jan 2014, 17:21
OS, Lazarus, FPC: Linux (die neusten Trunc)
CPU-Target: 64Bit
Wohnort: Schweiz

Re: Forum Weiterleitung crasht

Beitrag von Mathias »

Diese Meldung hatte ich auch schon, vor allem auf meinem Tablett mit Chrome.

Nachtrag, jetzt passiert mir dies auch auf dem PC. :roll:
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot

siro
Beiträge: 388
Registriert: Di 23. Aug 2016, 14:25
OS, Lazarus, FPC: Windows 10
CPU-Target: 64Bit
Wohnort: Berlin

Re: Forum Weiterleitung crasht

Beitrag von siro »

Diese Fehlermeldung habe ich grundsätzlich schon seit längerer Zeit. Ebenso beim Ein und Ausloggen,
habe mich aber schon daran gewöhnt und weiss, dass ich einfach die Seite neu aufrufen muss.....

Benutze Windows 8.1 und FireFox 53.0.3
identsiches Probelm aber auch mit dem Windows 7 Rechner.
Grad probiert auf Windows 10, nanu da geht es richtig..
Grüße von Siro
Bevor ich "C" ertragen muß, nehm ich lieber Lazarus...

Warf
Beiträge: 1480
Registriert: Di 23. Sep 2014, 17:46
OS, Lazarus, FPC: MacOS | Win 10 | Linux
CPU-Target: x86_64
Wohnort: Aachen

Re: Forum Weiterleitung crasht

Beitrag von Warf »

funktioniert bei euch ssl? denn mir ist aufgefallen dieser Fehler kommt nur wenn man über https drin ist, über http ist es problemlos möglich.

Marsmännchen
Beiträge: 294
Registriert: So 4. Mai 2014, 21:32
OS, Lazarus, FPC: Ubuntu 16.04, FPC 3.0.2, Lazarus 1.6.4
CPU-Target: 64bit
Wohnort: Berlin

Re: Forum Weiterleitung crasht

Beitrag von Marsmännchen »

Warf hat geschrieben:funktioniert bei euch ssl? denn mir ist aufgefallen dieser Fehler kommt nur wenn man über https drin ist, über http ist es problemlos möglich.
Bin kein Fachmann in diesen Sachen. Wie kann ich das unter Ubuntu überprüfen?
Edit: habe diesen Beitrag von meinem Handy gesendet... kein Crash.
Ich mag Pascal...

Warf
Beiträge: 1480
Registriert: Di 23. Sep 2014, 17:46
OS, Lazarus, FPC: MacOS | Win 10 | Linux
CPU-Target: x86_64
Wohnort: Aachen

Re: Forum Weiterleitung crasht

Beitrag von Warf »

Marsmännchen hat geschrieben:Bin kein Fachmann in diesen Sachen. Wie kann ich das unter Ubuntu überprüfen?
Edit: habe diesen Beitrag von meinem Handy gesendet... kein Crash.

Für HTTP (kein SSL) einfach http://www.lazarusforum.de aufrufen und für https (ssl verschlüsselt) https://www.lazarusforum.de

MitjaStachowiak
Lazarusforum e. V.
Beiträge: 357
Registriert: Sa 15. Mai 2010, 13:46
CPU-Target: 64 bit
Kontaktdaten:

Re: Forum Weiterleitung crasht

Beitrag von MitjaStachowiak »

Bei den Seiten mit Fehlermeldung einfach das :80 aus dem Hostname entfernen, dann geht's. HTTPS benutzt einen anderen Port.

Aber es nervt. Wäre schön, wenn das mal richtig konfiguriert würde. Ich frage mich sowieso, woher das :80 kommt.

Mathias
Beiträge: 5039
Registriert: Do 2. Jan 2014, 17:21
OS, Lazarus, FPC: Linux (die neusten Trunc)
CPU-Target: 64Bit
Wohnort: Schweiz

Re: Forum Weiterleitung crasht

Beitrag von Mathias »

MitjaStachowiak hat geschrieben:Bei den Seiten mit Fehlermeldung einfach das :80 aus dem Hostname entfernen, dann geht's. HTTPS benutzt einen anderen Port.

Aber es nervt. Wäre schön, wenn das mal richtig konfiguriert würde. Ich frage mich sowieso, woher das :80 kommt.

Das konnte ich bis jetzt auch nachvollziehen, das komische dabei, je nach Lust und Laune hat es ein :80 in der URL.
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot

Warf
Beiträge: 1480
Registriert: Di 23. Sep 2014, 17:46
OS, Lazarus, FPC: MacOS | Win 10 | Linux
CPU-Target: x86_64
Wohnort: Aachen

Re: Forum Weiterleitung crasht

Beitrag von Warf »

Mathias hat geschrieben:
MitjaStachowiak hat geschrieben:Bei den Seiten mit Fehlermeldung einfach das :80 aus dem Hostname entfernen, dann geht's. HTTPS benutzt einen anderen Port.

Aber es nervt. Wäre schön, wenn das mal richtig konfiguriert würde. Ich frage mich sowieso, woher das :80 kommt.

Das konnte ich bis jetzt auch nachvollziehen, das komische dabei, je nach Lust und Laune hat es ein :80 in der URL.


Die 80 kommt nur wenn man über https auf das Forum zugreift. Wenn man auf http://lazarusforum.de geht steht sie nicht da

Mathias
Beiträge: 5039
Registriert: Do 2. Jan 2014, 17:21
OS, Lazarus, FPC: Linux (die neusten Trunc)
CPU-Target: 64Bit
Wohnort: Schweiz

Re: Forum Weiterleitung crasht

Beitrag von Mathias »

Ich habe noch vergessen zu sagen, das dies bei den email-Benachrichtigungen auftaucht. Einmal hat es die :80 das andere mal nicht.
Mit Lazarus sehe ich gün
Mit Java und C/C++ sehe ich rot

pluto
Lazarusforum e. V.
Beiträge: 7114
Registriert: So 19. Nov 2006, 12:06
OS, Lazarus, FPC: Linux Mint 19.3
CPU-Target: AMD
Wohnort: Oldenburg(Oldenburg)

Re: Forum Weiterleitung crasht

Beitrag von pluto »

Ich habe noch vergessen zu sagen, das dies bei den email-Benachrichtigungen auftaucht. Einmal hat es die :80 das andere mal nicht.

Von Zeit zu Zeit beobachte ich das auch. Jetzt waren schon lange keine :80 mehr in den Links. Was ich komisch fand:
Ich klicke auf den Link, der Link öffnet sich, ich gebe meine Login Daten ein und anschließend taucht die :80 auf.
MFG
Michael Springwald

corado
Beiträge: 44
Registriert: Mi 7. Aug 2013, 17:00

Re: Forum Weiterleitung crasht

Beitrag von corado »

ich hatte die ebenfalls gerade mit Firefox und Opera...
Das Forum ist mit diesen nicht nutzbar :-(

MacWomble
Lazarusforum e. V.
Beiträge: 977
Registriert: Do 17. Apr 2008, 01:59
OS, Lazarus, FPC: Mint 19.3 Cinnamon / FPC/Lazarus
CPU-Target: Intel i7 64/32 Bit
Wohnort: Freiburg

Re: Forum Weiterleitung crasht

Beitrag von MacWomble »

corado hat geschrieben:Das Forum ist mit diesen nicht nutzbar :-(


Why not? bei mir geht alles Firefox 56
Alle sagten, dass es unmöglich sei - bis einer kam und es einfach gemacht hat.

pluto
Lazarusforum e. V.
Beiträge: 7114
Registriert: So 19. Nov 2006, 12:06
OS, Lazarus, FPC: Linux Mint 19.3
CPU-Target: AMD
Wohnort: Oldenburg(Oldenburg)

Re: Forum Weiterleitung crasht

Beitrag von pluto »

Ich hatte auch Probleme, weil Chrome wollte den Link in der E-mail nicht öffnen, weil die Seite nicht sicher sei, ich bin dann einfach "Manuell" in das Forum gegangen.

Ich frage mich ja, warum in der Benachrichtigungen immer noch HTTP und nicht HTTPS verwendet wird....
Auch jetzt zeigt Chrome an, "Nicht Sicher"....
MFG
Michael Springwald

MitjaStachowiak
Lazarusforum e. V.
Beiträge: 357
Registriert: Sa 15. Mai 2010, 13:46
CPU-Target: 64 bit
Kontaktdaten:

Re: Forum Weiterleitung crasht

Beitrag von MitjaStachowiak »

Wird Zeit, das Forum neu zu machen :wink:

Antworten