[gelöst] IXtst nicht gefunden beim compilieren / linken

Für alles, was in den übrigen Lazarusthemen keinen Platz, aber mit Lazarus zutun hat.
Antworten
kjer
Beiträge: 6
Registriert: Mi 15. Apr 2015, 10:34

[gelöst] IXtst nicht gefunden beim compilieren / linken

Beitrag von kjer »

Hallo,

ich versuche im Verzeichnis Lazarus/test Projekt runtests zu compilieren, bekomme die Meldung:
"Error: /usr/bin/ld.bfd: cannot find -lXtst"
Mit runtestsgui das Gleiche.

Konstellation:
Lazarus 2.3.0 (rev main-2_3-1918-ge886d9a126) FPC 3.2.2 x86_64-linux-gtk2

War bei Lazarus 2.2.0 genauso, deswegen der Laz 2.3- Install ( der gut geklappt hat auf Linux MX )

Scheint soweit ich seh ein Linker-Problem zu sein?!?, ich finde nirgendwo irgendwas über diese IXtst.

( Andere getestete Projekte compilieren bis jetzt völlig OK)

Jemand eine Idee?

Dank vorab!
Zuletzt geändert von kjer am Fr 2. Sep 2022, 15:14, insgesamt 1-mal geändert.

Benutzeravatar
theo
Beiträge: 9265
Registriert: Mo 11. Sep 2006, 19:01

Re: IXtst nicht gefunden beim compilieren / linken

Beitrag von theo »

Funzt bei mir auf OpenSUSE Leap.
Hast du das (oder ein für deine Distri entsprechendes Package)?
libXtst-devel - Development files for the X11 XTEST and RECORD extensions

kjer
Beiträge: 6
Registriert: Mi 15. Apr 2015, 10:34

Re: IXtst nicht gefunden beim compilieren / linken

Beitrag von kjer »

theo hat geschrieben:
Do 1. Sep 2022, 15:21
...
Hast du das (oder ein für deine Distri entsprechendes Package)?
libXtst-devel - Development files for the X11 XTEST and RECORD extensions
Dank für schnelle Response!

da existiert diverses als instaliert gemeldetes, aber evtl leicht anders benannt(dev statt devel)?:

libxtst-dev/stable 2:1.2.3-1 amd64
libxtst-dev/stable 2:1.2.3-1 i386
libxtst-doc/stable,stable 2:1.2.3-1 all
libxtst6/stable,now 2:1.2.3-1 amd64 [installed,automatic]
libxtst6/stable 2:1.2.3-1 i386

kjer
Beiträge: 6
Registriert: Mi 15. Apr 2015, 10:34

Re: IXtst nicht gefunden beim compilieren / linken

Beitrag von kjer »

man könnte fast den Eindruck bekommen, dass das in der rpm- Welt mit devel ausbuchstabiert wird,
in der deb - Welt mit dev ?

https://rpmfind.net/linux/rpm2html/sear ... Xtst-devel

https://packages.debian.org/de/sid/libx11-dev

Benutzeravatar
theo
Beiträge: 9265
Registriert: Mo 11. Sep 2006, 19:01

Re: IXtst nicht gefunden beim compilieren / linken

Beitrag von theo »

Dev oder devel spielt keine Rolle. Die Devel-Pakete liefern meistens Symlinks.
Hast du in /usr/lib64/ (oder deiner Distri entsprechend):
libXtst.so.6.10
libXtst.so.6 ->
libXtst.so ->
Bsp. von OpenSUSE Leap.

kjer
Beiträge: 6
Registriert: Mi 15. Apr 2015, 10:34

Re: IXtst nicht gefunden beim compilieren / linken

Beitrag von kjer »

in /usr/lib/x86_64-linux-gnu/ in dieser MX-Linux-installation ( aktuell ) gibts:

libXtst.so.6 ->
libXtst.so.6.1.0

(und auch
libXt.so.6 ->
libXt.so.6.0.0 )

Benutzeravatar
theo
Beiträge: 9265
Registriert: Mo 11. Sep 2006, 19:01

Re: IXtst nicht gefunden beim compilieren / linken

Beitrag von theo »

Aber es fehlt libXtst.so. Diese wird gesucht.
Erstelle manuell einen Symlink.
libXtst.so -> libXtst.so.6.1.0

kjer
Beiträge: 6
Registriert: Mi 15. Apr 2015, 10:34

Re: IXtst nicht gefunden beim compilieren / linken

Beitrag von kjer »

gerade gemacht, funktioniert, wunderbar! Danke!!

Antworten